・・・するだけでした

とまぁちょっとバージョンのお話でも

DBの操作で複数のレコードをinsertしたいことってありますよね

INSERT INTO TABLE_NAME (‘COLUMN_1’, ‘COLUMN_2’)
VALUES
(VALUE_11, VALUE_12),
(VALUE_21, VALUE_22);

こういうSQL文の書き方があります

僕はpostgreSQLをメインで使っていて、webサーバーとしてCentOSで構築しました

Windowsで開発していた段階ではその部分に不具合は出なかったのですが

CentOSの方に移行したらナゾのエラー・・・・

実はこのSQLの書き方、postgreSQLのバージョンが8.2以降だというのです

2011年8月あたりでは、yumでインストールされるpostgreSQLのバージョンは8.1

いやー、危ない危ない

あ、そうそうCentOSでもバージョンの関係で気をつけたい?ことがありました

apacheの設定でSSLのモジュール(mod_ssl)をインストールしました

・・・・もちろん、yumで

なんかCentOS5.6ではちょっとした不具合?があるらしく

初めてインストールされるときには、一度オーナーをrootにしてインストールして

グループの設定がおかしくなる?というようなことがあるらしく

そうなった場合、apacheからmod_sslが呼び出せなくなってしまい

apacheが起動できなくなるということに!

他のモジュールをインストールしただけで起動できなくなるなんて怖すぎます

対処法は一度removeしてインストールし直すと直りました

いや、知ってれば2,3分で解決する内容ですが

丸一日消費しました こういうのの対処法を教えてくださいダ・レ・カー

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

*